• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Delay action

First of all I would like to thank the creator for this app. And I'm glad it's developing - got update today with dark theme. Awesome  Heart

I don't know if it should be a feature/improvement request or a bug.

I've got an action configured at computer startup - downloading a file. And always after startup this task has an Error in status, that it cannot resolve host.  Looks like it's trying to download this file before Windows connects to network (I am connected via wire).
Didn't find any logs in app's folder.

So in brief: I would like to set any delay time (in minutes e.g.) as an action before execute next action. Is it possible? Or does anyone have a better idea?
If something is unclear, just ask

Hi Stivo,

Many thanks for the feedback!

I wonder if you manually execute the task after Windows has fully booted does it work properly? Otherwise I'll have a look and see if I can implement such a feature.

Have a nice day,
Actually, I've had a look and already released a new version with this feature Smile Let me know if it worked!
Really? Thank you!

I can confirm that it works when computer starts. But I forget one thing - I am waking up it from hibernate. And just a moment ago it doesn't download the file. I have to test it more.

PS. I thought that delay could be an action so it could work with any action, not only with starting a computer. But it depends on you, and I will understand your decision.
I second stivo's request for a means of delaying an action. I'm using robointern to automate the opening of several apps in sequence and need a way of delaying activation of the next action either by time, or until the previous app fully opens.
Hi Snoopy987, Stivo,

I've just released a new version which will wait for programs to load before marking the task done. Furthermore, I've also added an option to wait for the program to close / finish before continuing. I didn't number this version yet (don't want to flood users with update notifications Smile ), but you can just update by deleting the version.txt file in the config folder and then restarting RoboIntern. Let me know if it worked!

@Stivo, I think the delay is mostly relevant when running programs, which RoboIntern can't tell whether they have started (or finished) properly, therefore I didn't roll this out to all actions. I'll still contemplate though to which actions this could be relevant.
But I am still having error with unrecognized host (now it's in polish) even after set 4 minutes of delay
[Here was the picture, but I don't know what was happened?]

And Reset task button in some tasks cause Robointern's crash.
Hi Stivo,

I wonder could send over your config.xml (from the \config\ folder) to contact@robointern.tech, so that I can have a look?

It looks that the task is downloading from a website, it could be that some special authentication is required .

Sure, I've send it few seconds ago.

Forum Jump:

Users browsing this thread: 1 Guest(s)